
How To Use Excel
From adding data to writing a macro!



What is excel

 The ultimate software tool for financial analysis.

 Microsoft Excel is a program in the Office 365 suite typically used to store, 

sort, and manipulate data. Although Excel is not a database, it is often used 

in data analytics and finance careers to assess large amounts of information 

and create visualizations.

 Excel is a spreadsheet program in the Microsoft Office system. You can use 

Excel to create and format workbooks (a collection of spreadsheets) in order 

to analyze data and make more informed business decisions.

 Excel formulas enable you to perform calculations such as addition, 

subtraction, multiplication, and division. In addition to these, you can find 

out averages and calculate percentages in excel for a range of cells, 

manipulate date and time values, and do a lot more.



Workbooks vs. spreadsheets

 There’s something we should clear up before we move on.

 A workbook is an Excel file (which contains one or more spreadsheets). It 

usually has a file extension of .XLSX (if you’re using an older version of Excel, 

it could be .XLS).

 A spreadsheet is a single sheet inside a workbook. There can be many sheets 

inside of a workbook, and they’re accessed via the tabs at the bottom of the 

screen.

 A spreadsheet (a.k.a. a sheet/tab) contains all the cells you can see and use 

in the >1 million rows >16,000 columns.

 To muddy the water a Spreadsheet can also be a Libre Office Calc file (which 

contains one or more sheets). It usually has a file extension of .ods.

https://spreadsheeto.com/workbook/


Create a new workbook

 Excel documents are called workbooks. Each workbook has sheets, typically 

called spreadsheets. You can add as many sheets as you want to a workbook, or 

you can create new workbooks to keep your data separate.

 Click File, and then click New.

 Under New, click the Blank workbook.



Enter your data

 Click an empty cell.

 For example, cell A1 on a new sheet. Cells are referenced by their location in the 

row and column on the sheet, so cell A1 is in the first row of column A.

 Type text or a number in the cell.

 Press Enter or Tab to move to the next cell.



Apply cell borders

 Select the cell or range of cells that you want to add a border to.

 On the Home tab, in the Font group, click the arrow next to Borders, and 

then click the border style that you want.



Apply cell shading

 Select the cell or range of cells that you want to apply cell shading to.

 On the Home tab, in the Font group, choose the arrow next to Fill Colour, 

and then under Theme Colours or Standard Colours, select the colour that 

you want.



Use AutoSum to add your data

 When you’ve entered numbers in your sheet, you might want to add them up. A 

fast way to do that is by using AutoSum.

 Select the cell to the right or below the numbers you want to add.

 Click the Home tab, and then click AutoSum in the Editing group.

 AutoSum adds up the numbers and shows the result in the cell you selected.



Create a simple formula

 Adding numbers is just one of the things you can do, but Excel can do other 

math as well. Try some simple formulas to add, subtract, multiply, or divide 

your numbers.

 Pick a cell, and then type an equal sign (=).

 That tells Excel that this cell will contain a formula.

 Type a combination of numbers and calculation operators, like the plus sign 

(+) for addition, the minus sign (-) for subtraction, the asterisk (*) for 

multiplication, or the forward slash (/) for division.

 For example, enter =2+4, =4-2, =2*4, or =4/2.

 Press Enter.

 This runs the calculation.

 You can also press Ctrl+Enter if you want the cursor to stay on the active cell.



Apply a number format
 To distinguish between different types of numbers, add a format, 

like currency, percentages, or dates.

 Select the cells that have numbers you want to format.

 Click the Home tab, and then click the arrow in the General box.

 Pick a number format.

 If you don’t see the number format you’re looking for, click More 

Number Formats.



Put your data in a table
 A simple way to access Excel’s power is to put your data in a table. That 

lets you quickly filter or sort your data.

 Select your data by clicking the first cell and dragging to the last cell in 

your data.

 To use the keyboard, hold down Shift while you press the arrow keys to 

select your data.

 Click the Quick Analysis button     in the                                     

bottom-right corner of the selection.

 Click Tables, move your cursor                                                                                  

to the Table button to preview your 

data, and then click the Table button.



Put your data in a table (cont.)

 Click the arrow in the table header of a column.

 To filter the data, clear the Select All check box, and                                          

then select the data you want to show in your table.

 To sort the data,

 click Sort A to Z

 or Sort Z to A.

 Click OK.



Show totals for your numbers using Quick Analysis

 The Quick Analysis tool (available in Excel 2016 and Excel 2013 only) let you 

total your numbers quickly. Whether it’s a sum, average, or count you want, 

Excel shows the calculation results right below or next to your numbers.

 Select the cells that contain numbers you want to add or count.

 Click the Quick Analysis button     in the bottom-right corner of the selection.

 Click Totals, move your cursor across the buttons to see the calculation 

results for your data, and then click the button to apply the totals.



Add meaning to your data using Quick Analysis

 Conditional formatting or sparklines can highlight your most important data or 

show data trends. Use the Quick Analysis tool (available in Excel 2016 and 

Excel 2013 only) for a Live Preview to try it out.

 Select the data you want to examine more closely.

 Click the Quick Analysis button     in the bottom-right corner of the selection.

 Explore the options on the Formatting and Sparklines tabs to see how they 

affect your data.

 For example, pick a colour scale in the Formatting gallery to differentiate 

high, medium, and low temperatures.

 When you like what you see, click that option.



Show your data in a chart using Quick Analysis

 The Quick Analysis tool (available in Excel 2016 and Excel 2013 only) 

recommends the right chart for your data and gives you a visual presentation 

in just a few clicks.

 Select the cells that contain the data you want to show in a chart.

 Click the Quick Analysis button in the bottom-right corner of the selection.

 Click the Charts tab, move across the recommended charts to see which one 

looks best for your data, and then click the one that you want.

 Note: Excel shows different charts in this gallery, depending on what’s 

recommended for your data.



Sort your data
 To quickly sort your data

 Select a range of data, such as A1:L5 (multiple rows and columns) or C1:C80 (a single 

column). The range can include titles that you created to identify columns or rows.

 Select a single cell in the column on which you want to sort.

 Click to perform an ascending sort (A to Z or smallest number to largest).

 Click to perform a descending sort (Z to A or largest number to smallest).

 To sort by specific criteria

 Select a single cell anywhere in the range that you want to sort.

 On the Data tab, in the Sort & Filter group, choose Sort.

 The Sort dialog box appears.

 In the Sort by list, select the first column on which you want to sort.

 In the Sort On list, select either Values, Cell Colour, Font Colour, or Cell Icon.

 In the Order list, select the order that you want to apply to the sort operation —

alphabetically or numerically ascending or descending (that is, A to Z or Z to A for text or 

lower to higher or higher to lower for numbers).



Filter your data

 Select the data that you want to filter.

 On the Data tab, in the Sort & Filter group, click Filter.

 Click the arrow in the column header to display a list in which you can make 

filter choices.

 To select by values, in the list, clear the (Select All) check box. This removes 

the check marks from all the check boxes. Then, select only the values you 

want to see, and click OK to see the results.



Save your work

 Click the Save button on the Quick Access Toolbar, or press Ctrl+S.

 If you’ve saved your work before, you’re done.

 If this is the first time you've save this file:

 Under Save As, pick where to save your workbook, and then browse to a folder.

 In the File name box, enter a name for your workbook.

 Click Save.



Print your work

 Click File, and then click Print, or press Ctrl+P.

 Preview the pages by clicking the Next Page and Previous Page arrows.

 The preview window displays the pages in black and white or in colour, 

depending on your printer settings.

 If you don’t like how your pages will be printed, you can change page margins 

or add page breaks.

 You can also select a range of cells only to print before pressing Ctrl+P.  

Remember to check that the option for what to print is set to ‘Selection’.

 Click Print.

https://support.microsoft.com/en-gb/office/insert-move-or-delete-page-breaks-in-a-worksheet-ad3dc726-beec-4a4c-861f-ed640612bdc2


Activate and use an add-in

 On the File tab, choose Options, and then choose the Add-Ins category.

 Near the bottom of the Excel Options dialog box, make sure that Excel Add-

ins is selected in the Manage box, and then click Go.

 In the Add-Ins dialog box, select the check boxes the add-ins that you want to 

use, and then click OK.

 If Excel displays a message that states it can't run this add-in and prompts you 

to install it, click Yes to install the add-ins.



Find and apply a template

 Excel allows you:

 to apply built-in templates, 

 to apply your own custom templates, 

 and to search from a variety of templates on Office.com. 

 Office.com provides a wide selection of popular Excel templates, including 

budgets.



Write a Macro – What is a Macro?
 Macros for Excel are instructions you can customise to complete repetitive 

tasks automatically. 

 Implementing macros in different types of software can help save users time 
when working on repetitive tasks, like filling in cells. 

 Software developers can create macros by using the programming language 
Visual Basic for Applications. 

 Macros provide an automated input sequence that allows users to imitate 
keystrokes, mouse actions and other basic inputs. 

 Generally, macros are a way to automate repetitive tasks that are the same.

 Typically, these types of inputs are common in spreadsheet software 
applications like Excel. 

 Using macros with little understanding of what they do can be problematic 
because nefarious users, such as hackers, can use macros as a route of entry 
to install viruses, malware or adware onto computers or networks. 

 It's due to this threat that most programs, including Excel, disable macros by 
default.



Enabling macros in Excel for individual sessions
 Enabling macros for a single session of Excel gives you the option to use 

macros without changing the default settings of Excel. 

 Once you complete your single session, it's best to automatically disable 
macro to ensure security. 

 To enable macros in Excel for a single session, follow these steps.

 Open 'Excel' and the 'macro file': Once you have Excel running, open the file that 
contains the macro you intend to use. Once you open this file, Excel is going to 
display a yellow box with a security warning to let you know that macros are 
currently disabled.

 Click on the 'info' tab: Click on the 'file' option located at the upper left portion of 
the toolbar and select the 'info' option.

 Enable macros: From the 'security warning' option, click on 'enable content' and 
you're going to see a drop down menu. From here, click 'advanced options', select 
'enable content for this session' and click 'OK' to confirm that you have enabled 
macros for this session.

 Make sure to disable macros for the next session: Although it typically occurs 
automatically, it's worthwhile to make sure during your next Excel session that 
macros remain disabled. In this case, you're going to see the same yellow box with 
the security warning.



Enabling macros permanently in Excel
 If you are looking to use macros on a permanent basis in Excel, you can speak with the 

system administrator to discuss the risks. 

 You are essentially keeping a door open which could let dangerous viruses into your 
network, so permanently enabling macros might be a serious risk. 

 If you are sure you want to keep macros on permanently in Excel, follow these steps.

 Open your 'Excel file': While in Excel, open the macro file that you wish to use. It's going to 
have a yellow security message box to let you know that macros are currently disabled.

 Locate the Trust Center: The Trust Center is where you can alter and adjust the security and 
privacy settings within Excel and other Microsoft Office applications. You can locate it by 
clicking 'File', then 'Options' and 'Trust Center' from the navigation panel on the upper left 
portion of the screen.

 Find ‘Macro Settings': From within the Trust Center, you can adjust settings related to the 
security of data and documents. Click 'Trust Center Settings' and select 'Macro Settings'.

 Enable all macros: From within macro settings, click on the 'Enable all macros' button and 
confirm it by clicking 'OK'. A warning message is going to appear which tells you to avoid 
enabling all macros due to the risks of dangerous code affecting your computer or network.

 Know how to disable macros in the future: If you want to disable macros after permanently 
enabling them, you can return to the Trust Center and click on 'Disable all macros with 
notifications.'



Changing macro settings in Excel
 Enabling macros temporarily or permanently can help you work smarter 

within Excel. 

 If you want to get more value out of using macros, you can tweak macro 

settings from within Excel. 

 To do this, follow these steps.

 Open 'Microsoft Excel': To begin, launch Microsoft Excel on your computer to start 

the software.

 Select the 'Options' tab: On the upper left of the screen, click the 'File' tab and 

scroll down until you can see the 'Options' menu. Click on it and a new window is 

going to open up.

 Find the Trust Center: Scroll through the new window until you see the 'Trust 

Center' panel on the left side and click on it.

 Change macro settings: In the Trust Center, you have several options to choose 

from when changing the settings, like disabling all macros without notification, 

disabling all macros with notification and disable all macros except digitally signed 

macros. Once you have selected one, click 'OK' to complete the process.



How to record Excel macros
 Click on the View tab in the Excel ribbon

 Next, click on the Macros button on the right side of the View ribbon

 This will open the Macros drop-down.

 Click Record Macro.



How to record Excel macros (cont.)

 Enter a name for your macro, 

something like Hide_Columns.

 Excel macros can be stored in the Personal 

Macro Workbook. 

 This is saved in the system files of Microsoft 

Excel and macros saved here can be used in 

other workbooks.

 For this Excel macro tutorial, you only need to 

save the macros in the current Excel file.

 Select Store macro in: This Workbook then 

click the OK button.

https://spreadsheeto.com/wp-content/uploads/2022/09/06-store-macro-in.png
https://spreadsheeto.com/wp-content/uploads/2022/09/06-store-macro-in.png


How to record Excel macros (cont.)
 Excel is now recording your actions to create a 

macro.

 Select Columns A & B and then right-click on the 

highlighted Column Bar to Hide them.

 Then select Column I and press Ctrl + Shift + Right 

Arrow to include all remaining columns on the right.

 Right-click on the highlighted Column Bar then click 

on Hide.

 Your worksheet should now look like this:



How to record Excel macros (cont.)
 To end the macro recording:

 On the View ribbon, click on Macros and select Stop Recording.

 Good job!  

 You have created your first macro in Excel!



How to record Excel macros (cont.)

 But wait, where is the recorded macro?

 To view all of the available Excel macros :

 Select View Macros.

 This opens the Macro window. Saved macros will be 
listed here and you can Run whichever one you need.

 You can also click on Edit to view the VBA code 
window.

 The VBA code editor opens.

 Notice the Hide_Columns Sub procedure. You don’t 
have to write or edit VBA code for the macro.

 Excel automatically generated each code line based 
on the recorded keystrokes and mouse clicks.

 The Record Macro feature is powerful enough for 
general spreadsheet automation needs.



How to record Excel macros (cont.)
 Using the Developer tab

 Let’s record another macro to Unhide the hidden columns.

 This time, you can record the macro from the Developer tab.

 The Developer tab gives you access to a lot of useful Microsoft Excel features 

such as the Visual Basic Editor. It also allows you to quickly insert form 

controls such as buttons and checkboxes.

 However, the Developer tab is not visible in the Excel ribbon by default.

 To add it:

 Right-click on the Excel ribbon.

 Select Customize the Ribbon.

 This opens the Customize Ribbon window.

 On the right side, check the Developer tab checkbox.

https://spreadsheeto.com/vba-editor/
https://spreadsheeto.com/checkbox-excel/
https://spreadsheeto.com/developer-tab/


How to record Excel macros (cont.)

 You should now see the Developer tab.

 To start recording the Unhide macro:

 Click on the Record Macro button in the Developer tab.

 Name this macro Unhide_Columns.

 Click OK.

 The recording has started.

 Press Ctrl + A twice to select all cells.



How to record Excel macros (cont.)

 Right-click anywhere on the Column Bar then click Unhide.

 Click on the Stop Recording macro button to finish up.

 Great work!  

 Now you have two recorded macros that can be executed.



How to run an Excel macro
 To run your macros:

 Click on the Macros button from the Developer tab.

 In the Macro window, select the 

macro Hide_Columns and click on Run.

 The macro executes the actions recorded earlier and 

hides the unnecessary columns.

 You can also run macros from the View ribbon.

 Run Excel macro from the View tab

 This time, run the Unhide_Columns to show all the 

columns.

 On the View ribbon, click the Macros button and 

select View Macros.

 Select the Unhide_Columns macro and Run it.

 This unhides all the columns in the worksheet.

 As you can see, the Macro window allows you to 

quickly run all the available macros.



Run Excel macro from a button
 For this next example, you will assign macros to buttons 

which will be located on top of the table.

 Insert 2 rows above the table headers. Select Row 1 then 
press Ctrl + Shift + Plus Sign(+) twice.

 To create a button, click 
on Insert > Illustrations > Shapes.

 Then select the Rectangle.

 Draw a rectangle and format it as you’d like. Label it 
“HIDE”.

 This will be your HIDE button. Place it between columns A 
& B so it will be hidden with the columns when the macro 
runs.



Run Excel macro from a button (cont.)

 To assign a macro, right-click the shape and select Assign 

Macro.

 In the Assign Macro window, select Hide_Columns and 

click OK.

 The Hide button now works!



Run Excel macro from a button (cont.)
 Now, do the same for the Unhide_Columns macro.

 6. Create another rectangle button and label it “UNHIDE”.

 Ass above, to assign a macro, right-click the shape and 

select Assign Macro.

 In the Assign Macro window, select Unhide_Columns and 

click OK.

 The Unhide button now works!

 Now you can quickly run your macros using 

the HIDE and UNHIDE buttons.



Run Excel macro from a shortcut key

 It is sometimes better to run macros using a keyboard shortcut.

 For this next example, you want to quickly highlight people on the 

list that expressed interest in the business.

 To create a macro for this:

 Select any cell within the table.

 On the Developer tab, toggle ON the Use Relative 

References button.

 Start recording with the Record Macro button 

on the Developer tab.

 Or, you can also click the Record Macro button 

on the Status Bar.

https://spreadsheeto.com/status-bar-excel/


Run Excel macro from a shortcut key (cont.)

 Name the macro Mark_Interested.

 Then assign a shortcut key. For example, Ctrl + Q.

 Click OK. The recording has now started.

 Highlight the row of the Active Cell using the keyboard 

shortcut Shift + Space Bar.

 When selecting cells or expanding selections while recording a 

macro, it is best to use keyboard shortcuts.

 This is so that Excel can record the selections as relative 

references.

 For example, if you select Row 4 by clicking on the Row Bar, Excel 

will record this as an absolute reference. This means it will always 

select Row 4 regardless of the currently Active Cell.



Run Excel macro from a shortcut key (cont.)

 When you use the Shift + Space Bar shortcut instead, it tells Excel to select the 

row of the current Active Cell.

 Apply the formatting:

 Fill using the color Green

 Change font color to White

 End the macro recording from the Status Bar

 All done!

 Try to use the shortcut Ctrl + Q to quickly apply formatting to entire rows.



Saving macro-enabled workbooks

 If you save the practice workbook, this window will pop up:

 This is because the practice workbook is currently saved with the .xlsx file 

extension which does not support macro features.

 To save properly, change it to the .xlsm file extension for macro-enable 

workbooks by using the ‘Save-As’ option.

 Keep this in mind when saving your work.


